openMairie.org | Démonstration | Documentation | Forum

Installation Base


#1

Bonjour,

J’essaye d’installé open cimentière mais je rencontre des difficultés avec la configuration de la base de données.

Voici ma configuration:
Windows 10, Wamp Version 3.0.6 et PostgreSql Version 9.6.0

j’ai créé la base sans problèmes, puis j’ai exécuté les scripts qui se trouvent dans le répertoire: C:\wamp\www\opencimetiere\data\pgsql

J’ai des erreurs de syntaxe comme par exemple:

SET search_path = :schema_oc, public, pg_catalog; --> Les : ne sont pas accepter, la ligne de commande semble être SET search_path TO schema_oc, public, pg_catalog;

Pouvez-vous m’aider car je suis un peu perdu.

D’avance je vous remercie,

Cordialement,
Didier


#2

Bonjour,

Êtes-vous toujours bloqué lors de l’installation de la base ? S’agit t-il de la version 3.0.0 d’openCimetière ?

Cette syntaxe “SET search_path = :schema_oc” permet d’accéder à la variable PL/pgSQL “schema_oc” définie un peu plus haut dans le fichier install.sql. Il est possible que l’erreur de syntaxe soit causée par votre environnement, surtout si vous utilisez une interface web pour accéder à votre base de données. Si c’est le cas vous pouvez essayer de lancer le script install.sql directement en ligne de commande.

Cordialement,
Jean-Yves


#3

Bonjour,

Oui je suis toujours bloqué mais je n’ai plus eu beaucoup cherché par maque de temps. Je crois aussi que le problème est du à mon environnement car je suis sous Windows.

Je vais installer une machine Linux, je crois que je gagnerai du temps.

Merci,


#4

Bonjour,

Je reviens vers vous pour avoir un complément d’informations.

j’ai installé une machine linux et effectué l’installation plus simplement que sous Windows. Cependant il me reste une erreur lors de l’exécution du script install.sql: aucun fichier ou dossier de ce type.

J’ai alors lancé les script manuellement sans problème sauf à partir de init_sig_extent.sql avec le message: duplicate key.

Cordialement,


#5

Je suis enfin connecté, le schéma n’était pas bon dans le fichier /var/www/html/opencimetiere/dyn/database.inc.php

J’ai modifier opencimetire par public et ça fonction.

Mais ne vais-je pas avoir des erreur ailleurs?

Cordialement,


#6

Bonjour,

C’est dur à dire de l’extérieur, mais si vous pouvez vous connecter à l’application je pense que vous n’aurez pas d’erreurs ailleurs.

Cordialement,
Jean-Yves


#7

Bonjour,

Open cimentière fonctionne sur mon serveur avec les bon paramètres.

J’ai rédigé une documentation qui permettra aux autres de l’installer chez eux: http://dl.free.fr/mZ4ndnPE4

Je complèterai cette documentation avec la partie de sauvegarde automatisée.

Didier


#8

Bonjour,

Pensez bien à re-sécuriser votre serveur après installation :wink:

Cordialement,

Thierry


#9

Bonjour, je suis novice en installation.Je me relance une nouvelle fois ( je n arrivais pas à créer les base sous easyphp windows )
Votre lien téléchargement n aboutis plus.
Vous serait il possible de m en renvoyer un autre lien.
Cordialement
Patrick “olaf”


#10

Bonjour,

Le PDF est disponible au téléchargement.

Si vous désirez, voici le lien vers une machine virtuelle VirtualBox, préinsatllée etr fonctionnelle:

http://dl.free.fr/vucFtRwiI

Cordialement,


#11

Super et merci encore

patrick ( holaf )


#12

super tout fonctionne


#13

Bonjour,

problème de page blanche


#14

Problème de page blanche lors de la connexion

http://localhost/opencimetiere/scr/login.php?came_from= me donne une page blanche

Quelle est la solution ?

Par avance, Merci de votre réponse.

Ppere42