openMairie.org | Démonstration | Documentation | Forum

Installation opencimetiere 3.0


#1

Bonjour,

J’ai installé opencimetiere 3.0 mais je rencontre un problème au moment de la connexion. A priori, la base PostgreSQL fonctionne bien , j’ai installé le serveur virtuel Wamp, je suis sous Windows 7 mais quand je tape http://localhost/opencimetiere/scr/login.php, j’ai toute uns série d’erreurs (cf. pièce jointe)
localhost_opencimetiere_scr_login.pdf (143,5 Ko)

Pourriez-vous me dire ce qui pose problème?

Merci d’avance,

Marine


#2

Bonjour,

Vous trouverez des informations à ce sujet dans la documentation du framework openMairie 4.5 sur lequel est basé openCimetière 3.0 : http://openmairie.readthedocs.io/projects/omframework/fr/4.5/installation/index.html#pre-requis

A savoir modifier la directive error_reporting du fichier “php.ini” dans votre configuration de Wamp :

error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

Florent.


Probleme connexion opencimetière
#3

Bonjour,

Merci pour la piste. J’ai modifié la directive error-reporting comme indiquée mais j’ai toujours les mêmes erreurs. Je mets le contenu de mon fichier php.ini en PJ. Est-ce qu’il y aurait une autre piste?

Merci d’avance.PHP_ini.docx (46,2 Ko)

Marine


#4

Il faut redémarrer apache pour que la modification du php.ini soit bien prise en compte.


#5

Merci. J’ai l’impression que je n’ai pas la bonne méthode pour redémarrer apache car j’ai toujours le même problème.

J’ai d’abord redémarré apache de cette manière
image


#6

puis en ligne de commande mais cela ne fonctionne pas,
image

Comment puis-je faire?
Merci d’avance


#7

Bonjour,

La première méthode pour redémarrer apache me paraît correcte.

Wampserver a plusieurs fichiers php.ini dans sa configuration, il faut que la modification en question soit faite dans le bon. Voici ce qui est écrit dans l’entête du php.ini transmis plus haut :

; **************************************************************
; ****** DO NOT EDIT THIS FILE **** DO NOT EDIT THIS FILE ******
; * This file is only use by PHP CLI (Command Line Interface)  *
; * that is to say by Wampserver internal PHP scripts          *
; * THE CORRECT FILE TO EDIT is Wampmanager Icon->PHP->php.ini *
; * that is wamp/bin/apache/apache2.x.y/bin/php.ini            *
; **************************************************************

#8

Merci, en effet c’était bien ça, le fichier php que j’avais modifié n’était pas le bon. Tout fonctionne :slightly_smiling_face:


#9

Problème de page blanche lors de la connection

Avec Ubuntu 16.04 (32-bit)
http://localhost/opencimetiere/scr/login.php : me donne une page blanche

Quelle est la solution ?

Par avance, Merci de votre réponse.

Ppere42