openMairie.org | Démonstration | Documentation | Forum

Erreur lors de la connexion à opencimetiere

bonjour à tous,
je souhaite proposer cette appli à ma commune. je l’ai installer sur linux avec succès grâce au tuto d’un membre (gratitude). je rencontre des soucis lors de l’install sur windows.
la config est la suivante :: windows xp, wampserver 2.4, postgresql 9.5, postgis-pg95. l’importation de la base de données via le script ne renvoi pas d’erreur.
lors de la connexion avec le compte de base admin, j’ai un tas d’erreur et je suis débutant dans le décryptage de celles-ci.
j’ai effectué une bonne recherche sur le net et tenter de modifier certains fichiers sans succès définitif.
je joins une capture d’écran du haut de la page du navigateur afin que quelqu’un puisse me donner un coup de main.


excellente journée
remi

Bonjour,

Tout d’abord une mise en garde sur windows XP, notamment en cette période fleurissante de “rançon-giciel”: c’est une plateforme vraiment obsolète d’un point de vue sécurité.
Ceci dit, les blocs d’avertissements PHP sont liés à la configuration du “moteur” PHP qui lui demande de respecter les “Strict standards” que le code PHP d’openCimetiere ne suit pas.

Il faut donc configurer Wamp pour qu’il ne contrôle pas ce strict respect des standards, comme indiqué ici: http://openmairie.readthedocs.io/projects/openmairie/fr/latest/installation/index.html#pre-requis

Trouver votre fichier “php.ini” et modifier la directive concernée comme ci-dessous:
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

Laurent

1 J'aime

Bonjour,
Merci pour votre réponse.
j’ai ouvert le liens cité.
L’install sur windows xp de wamp server avec php 5.5 > 5.6 n’est pas possible. j’ai sans doute tenté l’impossible avec la config xp-wamp 2.4-postgressql 2.5. J’ai cependant renseigné le fichier php.ini comme vous me l’avez indiqué et relancé la tentative de connexion. un écran blanc est arrivé. Je suis passé en mode debug (fichier debug.inc.php) et ceci s’est affiché ::
/opencimetiere/scr/login.php
class utils - database::isError(): SGBD ERROR => DB Error: extension not found] ** pgsql(pgsql)://postgres:PASSWORD@tcp+localhost:5432/opencimetiere?title=openCimetière&formatdate=AAAA-MM-JJ&schema=opencimetiere&prefixe=&directory=&mail=&filestorage=filestorage-default&extras DEBUG
class utils - database::isError(): PEAR ERROR => DB Error: extension not found DEBUG

l’extension pgsql_php.dll est activé dans le fichier php.ini .
Je suppose que faire plus serait de la perte de temps.
je vais tâcher de trouver un windows plus récent.

Merci beaucoup pour le temps que vous m’avez consacré et le savoir partagé.
excellente journée et week-end.
Rémi

Bonjour ,
je poste ce message pour rendre compte de mon essai sur windows vista. Avec wamp 3.0, postgresql 9.5 et postgis pour pg 9.5 . L’install s’est relativement bien passée (l’ajout de Microsoft visual c++ 2008- 2010-2012-2013 et 2015 à permis le fonctionnement nominal de wamp). J’ai du également modifier le fichier php.ini pour le report d’erreur afin d’obtenir la page de login.
Merci encore pour le coup de main.
Excellente journée
Rémi