openMairie.org | Démonstration | Documentation | Forum

Problème d'insertion de données vers la version 4.1

bonjours, je suis sous opencourrier sous une version inférieur à la 4.0 (donc sous mysql) et je souhaite passer à la 4.1, cependant, j’ai remarquer que beaucoup de tables possède des champs soient nouveaux ou avec des types différents. J’ai (en modifiant certaines valeurs etc…) importées mes tables les plus importantes (“emetteur” & “service”) mais lorsque j’essaye d’importer ma table “courrier” et que j’active le VERBOSE_MODE, je tombe sur le message d’erreur suivant :

0.405 : class utils - scr/import.php: db->getone(“select * from public.traitement where traitement = ‘4’”); VERBOSE
class utils - database::isError(): QUERY => select * from public.traitement where traitement = ‘4’ DEBUG
class utils - database::isError(): SGBD ERROR => nativecode=ERREUR: la relation « public.traitement » n’existe pas LINE 1: select * from public.traitement where traitement = ‘4’ ^ DEBUG
class utils - database::isError(): PEAR ERROR => DB Error: unknown error DEBUG

(je précise que dans la version précédente, le champ “traitement” était en chaine de caractère, j’ai donc modifier des valeurs)
cependant, ma relation avec service(service) devrai fonctionner vue que j’ai un service n°4 et je ne comprend pas pourquoi il va chercher une table “traitement” dans mon schema public sachant que aucune table de ce nom n’existe et à aucun moment il n’a fallu la créer (et je précise que dans l’ancienne version de opencourrier cette table n’existait dans la base) que faire s’il vous plaît :slight_smile:

Bonjour Rygegor,

je suis en train d’essayer d’effectuer cette migration aussi, et je suis confronté au même souci. J’ai bien modifié les valeurs (et la position des colonnes) dans mon fichier CSV, mais même problème sur la relation “public.traitement” qui n’existe pas.

Avez-vous réussi à régler votre problème ? Si oui, comment ?

cordialement,