openMairie.org | Démonstration | Documentation | Forum

Problème lors la création d'une élection

Bonjour a tous,
Je suis en train de faire un jeu d’essai pour les présidentielle, a la création de l’election j’ai ce message :

DB Error: unknown errorerreur INSERT INTO election (election, typeelection, election_date, election_libelle, election_tour, election_canton, election_nbcandidat, election_h_ouver, election_h_ferm, election_simulation, election_commentaire, election_option_publication) VALUES (‘PRE17-1C’, ‘PRE’, ‘2017-04-23’, ‘PRESIDENTIELLE2017 1C’, 1, ‘T’,‘11’, ‘08:00:00’, ‘18:00:00’, -1, ‘’, ‘’)

une petite aide svp

Bonjour,

Avez-vous pu résoudre votre problème ?

Cordialement

Bonjour,
Non pas du tout
Je suis vraiment pommé pour le coup
Je n’ai pas spécialement de compétence en php en plus après pour aller bidouiller dans le code

bonjour,
j’ai le même problème, quelqu’un a trouver ??

si tu as quelque chose ca m’interesse toujours

Bonjour,

Pour ma part, j’ai réglé ce problème en changeant le type de données du champ election_option_publication dans la table election de la base MySQL
Je l’ai mis en tinytext avec valeur Null à oui

Il faut faire de même pour le champ publication dans la table resultat.

Cordialement,
Frédéric

merci je vais me remettre dessus et essayer ceci

Bonjour,

j’ai le même problème pour créer une élection. Ma config wampserver 3.0.6 64 bits sur un serveur Windows server 2012 R2. j’ai essayé la manip de fred, mais ca m’indique "erreur de requête:#1101 - BLOB ‘election_option_publication’ ne peut avoir de valeur par défaut, idem pour la table resultat.
j’ai pu contourner le problème en ayant une version plus ancienne sur un pc en Windows 7 avec wampserver 2, j’ai créé l’élection sur celui ci et exporter les données vers le Windows 2012. tout fonctionne bien, mais j’aimerai pour la prochaine élection créer directement l’élection sur le serveur.

Bonjour,

personne n’a trouvé une solution à ce problème ?

Bonjour,

J’ai exactement le même soucis, j’ai modifié comme fred l’a fait.

Pas de changement…

Bonjour,

Pour ma part je n’ai aucun problème quand je crée une élection, ce qui est je pense dû à ma version de mySQL plus ancienne, la 5.6.31.

Est-ce que vous auriez un message d’erreur un peu plus détaillé ?

Cordialement,
Jean-Yves

Bonjour,

En effet pour ma part la version de mySQL est 5.7.14. j’ai récupéré un passage d’aujourd’hui dans le log de php-error quand j’essaie de créer une élection.
Télécharger le fichier de log php_error
Cordialement

Bonjour,

Merci de votre réponse

Pour ma part version mySQL 5.7.18

Je tente de réinstaller en version 5.6.31 pour vérifier, je vous tiens au courant

Cordialement,

Après réinstallation en version de mysql 5.6.31 cela ne fonctionne toujours pas…

Est t’il possible d’obtenir votre configuration globale ?

Merci

Cordialement,

J’ai résolu mon problème en installant xampp en version 3.2.2 qui a une version de PHP en 5.6.30 et mysql 5.0.11.